The charts below outline our components health – from fully operational, to degraded, to full outages. If you are experiencing an issue not listed here, please visit Support.

Please log in to see the history of incidents beyond what is currently happening.

Qlik Cloud® – Qlik Cloud & Talend Cloud – AWS – US East (N. Virginia)

Incident Report for Prod - Qlik Cloud Public

Update

AWS is still experiencing issues, which may affect your ability to open Qlik Cloud apps. We recommend retrying to open the app, and we will keep you updated with any further information.
Posted Oct 20, 2025 - 14:33 UTC

Update

AWS is still experiencing issues related to insufficient compute capacity errors, which may impact the ability to open your Qlik Cloud app. We suggest retrying to open the app, as systems are still recovering.
Posted Oct 20, 2025 - 11:24 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 09:41 UTC

Update

An AWS issue in the US-EAST-1 region is currently impacting our Cloud infrastructures.
We've identified that additional functionality is now affected as part of this ongoing issue — specifically: Talend Cloud TMC executions.
Check live status updates here: https://status.qlikcloud.com/
Posted Oct 20, 2025 - 08:25 UTC

Investigating

We’re investigating an issue affecting multiple areas of the platform, including: Login, API and open App with Qlik Cloud – US East (N. Virginia). Updates will be provided as new information becomes available during the resolution process. We apologize for any inconvenience and appreciate your patience.
Posted Oct 20, 2025 - 07:53 UTC