The charts below outline our components health – from fully operational, to degraded, to full outages. If you are experiencing an issue not listed here, please visit Support.

Please log in to see the history of incidents beyond what is currently happening.

Qlik Cloud® – AWS – US East (N. Virginia)

Incident Report for Prod - Qlik Cloud Public

Resolved

This incident has been resolved.
Posted Apr 11, 2026 - 00:30 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 10, 2026 - 22:02 UTC

Update

We continue to investigate issues with Qlik Cloud and are diligently working to resolve the issue plus putting in mitigation controls. Updates will be provided here as new information becomes available during the resolution process. We apologize for any inconvenience and appreciate your patience.
Posted Apr 10, 2026 - 19:56 UTC

Update

We continue to investigate issues with Qlik Cloud and are diligently working to resolve the issue plus putting in mitigation controls. Updates will be provided here as new information becomes available during the resolution process. We apologize for any inconvenience and appreciate your patience.
Posted Apr 10, 2026 - 17:55 UTC

Update

We continue to investigate issues with Qlik Cloud and are diligently working to resolve the issue plus putting in mitigation controls. Updates will be provided here as new information becomes available during the resolution process. We apologize for any inconvenience and appreciate your patience.
Posted Apr 10, 2026 - 16:25 UTC

Update

We continue to investigate issues with Qlik Cloud and are diligently working to resolve the issue as soon as possible. Updates will be provided here as new information becomes available during the resolution process. We apologize for any inconvenience and appreciate your patience.
Posted Apr 10, 2026 - 14:20 UTC

Investigating

We're investigating an issue affecting multiple areas of the platform, including: login failures, opening apps and reloads delays with Qlik Cloud – US East (N. Virginia).

Updates will be provided as new information becomes available during the resolution process. We apologize for any inconvenience and appreciate your patience.
Posted Apr 10, 2026 - 13:19 UTC
This incident affected: Qlik Cloud – AWS – US East (N. Virginia).